Scheduled Maintenance for Ozly eSIM APIs / Servers
Completed
Scheduled for February 23, 2026 at 11:00 PM – February 24, 2026 at 2:00 AM
Affects
Ozly Web App
Under maintenance from 11:00 PM to 2:00 AM
Ozly eSIM Provisioning API
Under maintenance from 11:00 PM to 2:00 AM
Updates
Completed
February 24, 2026 at 2:00 AM
Completed
February 24, 2026 at 2:00 AM
Maintenance has completed successfully
In progress
February 23, 2026 at 11:00 PM
In progress
February 23, 2026 at 11:00 PM
Maintenance is now in progress
Planned
February 23, 2026 at 11:00 PM
Planned
February 23, 2026 at 11:00 PM
We will be performing scheduled upgrades to our eSIM API and servers. During this time, eSIM activations may be slightly slower than usual. We apologise for any inconvenience and appreciate your patience while we improve our systems.